Sage: Soon to Retire

This is the last year that Sage will provide support for 4.30. The Q1 2013 Tax Table Update (TTU) and Year-End Interim Release Download (IRD) are the last ones that will be provided for 4.30. You will need to upgrade to a more current version of the software in order to receive future TTU’s or the 2013 941 form typically released at the end of the 1st quarter.

So, what if you are still on version 4.20 or older and need the TTU’s or an IRD? First of all, at the time this article was written we are not sure of any major changes to W-2’s, 1099’s, or efiling that will require an IRD. We will keep all end-users posted as information becomes available. So, if you find yourself still on version 4.20 and need to schedule an upgrade, please call Pam Scott at 502-429-6902 ext. 221 or pam@oasisky.com, to discuss your options. At this time we are unable to schedule any additional upgrades through the end of 2012, and your options will vary depending on if there is an IRD and the extent of the changes within the IRD.

You may also like

In 2024, we’re living in the future. Pocket-sized AI and portable workspaces have shown us that finding balance at work is as ...

NetSuite, the cloud-based enterprise resource planning (ERP) software, has released its 2024.1 version, packed with exciting features and enhancements to ...

Stay tuned on our ERP path!

Subscribe to our newsletter and get the latest news